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Chapter 1
General Information

Getting started.

General Information

¢ Introduction

¢ DSE Lite Installation

¢ Launching DSE Lite

¢ Connecting to the Drive
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General Information

Introduction

DSE Lite (Drive System Explorer Lite) is the software tool for the 890, 690+, 650V, 620 series firmware version
4.0 or later, 605, 590+, 590 series firmware version 3.2 or later, 590SP and 584SV range of drives available from
SSD Drives. Using straightforward block programming you can very quickly become a confident user of DSE Lite.
Users of CELite (Configuration Editor Lite) and DSD (Drive System Designer), two previous products, will
appreciate DSE Lite's similarity and familiar features. DSE Lite combines the features of both these previous
products into a single application with a modern interface and more advanced monitoring capabilities.

For the 584, 590, 605, 620, 650 and 690 drives DSE Lite provides parameterization and function block
connectivity similar to CELite. 890 drives support user defined applications in conjunction with fixed Motor
Control blocks. Similar to DSD’s support for Link Tech Boxes, DSE Lite allows the user to create, parameterize,
and configure user defined applications as well as parameterize and connect fixed Motor Control blocks:

I/0 Elements: the 890 supports a wide variety of I/O this includes DSE

built in analog and digital support as well as optional encoder and
field bus cards. 820 configuration/application

Application: this is the working space, external of the Motor Control I/O Bloc Molor
environment. In it you can place any number of instances of any Block
block - gone are the days of fixed numbers of blocks. Beyond that, I/O
the DSE Lite world is not flat - you can create well structured, multi-
layered applications using the Macro feature, which allows you to t
create a compound block representing an entire block diagram.

Motor Control: this is a fixed environment comprising drive and Application

motor parameters organized into blocks. You can parameterized
these blocks, or you can read and write to them by linking their Motor
parameters with blocks in the Application environment. Conftrol

Control
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DSE Lite Installation

The 890 Drive is supplied with a CD containing the DSE Lite Configuration Tool. The install file is also available
at www.ssddrives.com. You can install DSE Lite on any Intel based PC with the following minimum specification:

¢ Running native Windows XP, Home or Professional Edition

¢ 100MbD of free hard disk space

¢ A USB port is required for connecting to an 890 drive

¢ A Serial port is required for connecting to 690+, 650V, 620, 605, 590+, 590, 590SP and 584SV drives.
Insert the CD and execute the "setup . exe" file on the disk to install the latest LINK database and DSE Lite.
Follow the on-screen instructions.

Installing the USB driver

The DSE installation program "setup . exe" will copy TI USB driver files into the appropriate Windows
directories. This driver is needed for connect to an 890 via its USB port. When connecting to the 890 drive for the
first time, Windows will acknowledge that it has found new hardware with the "New Hardware Found" wizard.
When prompted for a driver, select the "Install automatically" option and select "OK".

The DSE Lite installation program "setup . exe" will also install a copy of the Texas USB drivers into:
C:\Program Files\Texas Instruments\USB-Serial Adapter

If the automatic install method fails, select the "Browse" option and select the directory above once prompted for a
driver by the Found New Hardware Wizard.

If you have already plugged in the 890 Drive and Windows has determined it to be an "Unknown/Other" device,
you must select the device in the Windows Device Manager (under the Unknown/Other Device Class). Display the
properties for the device (by double-clicking it), and then click the "Update Driver" button on the "Driver"
properties tab. This will then bring up a Wizard and you need to point to the directory of driver files as described
previously.
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Updating the USB driver

WARNING

The USB driver should only be updated if the current driver is causing problems. Updating the
driver should only be preformed by someone with extensive knowledge of Windows XP.

To update the USB driver from Windows Explorer, go to MyComputer (Right Click) = Properties - Hardware - Device Manager
- Multi-port serial adapters 2 TUSB3410 device—> (Right Click) = Update. If this does not work, you have to manually uninstall
the older version of the USB driver first:

l.

ok B

A S B

Open My Computer (Right Click) = Properties = Hardware - Device Manager = Multi-port serial
adapters = TUSB3410 device

TUSB3410 device (Right Click) = Uninstall.

Start = Run - regedit.

Go to HKEY LOCAL MACHINE/SYSTEM/CurrentControlSet/Enum/USB

If you have a Vid_0451&Pid 3410 this needs to be deleted
a. Vid 0451&Pid 3410(Right Click) = Permissions = Enable Allow Full Control for you = OK
b. Vid 0451&Pid 3410(Right Click) = Delete.

Go to HKEY LOCAL MACHINE/SYSTEM/CurrentControlSet/Enum/umpport

If you have this key, it needs deleting. Follow 5a and 5b to delete this key.

Delete umpusbxp . * and umpcomxp . * in windows/inf directory

Delete all of the oem* . * files that link to umpusbxp.inf and umpcomxp.inf. You need to do this
manually. Search string ump* . * and search files oem* . *

10.Delete umpusbxp.sys , umpusbvista.sys and ump£f3410.i51 filesin

windows/system32/drivers directory.

11.Restart computer before installing new driver.

Page 1-4
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Launching DSE Lite

Start DSE Lite by clicking its program icon in Windows or, in the Windows' Start Menu click on "All Programs",
you will see "SSD Drives", and within is "DSE Lite". Click on this to launch DSE Lite.

232 DSE Lite

! File Edit View Command  Window Hel
Parameters
{none)
Properties
Document Settings
Global Settings
B Yersion
Apphersion 2.00
Wiewy Layout curremnt
Language English
Scratch Pad 3o
D3E Lite wersion 2.00, Copyright Parker Hannifin Corporation 1985-2Z2007. A
Mon Oct 08 14:19:33 Z007
user name is 'DIE Lite Manusal'
loading 'c:%Dse\CELite3.dat' (ID #6145) done.
connected to '123' (890 w1.11) - OK, CPU 38.4%, Heap: 27.8%, 0 msgs/s
i, 111} ] l,
Ready Connected to 123" (OK) at 57600 ]
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General Information

Connecting to the Drive

2%€ DSE Lite There are now multiple ways to connect to a drive, USB cable,

! He Edt View Command window He Modem, Serial cable, and Ethernet. Some of the connections will
FY e R only work with specific drives, the following information will go Icpom
e —— : over each connection type. The drives they work with and how to set COM1O
them up. The Comm Port icon is shown on the Left, and the drop —
down menu is shown on the left. COM12
COM13
USB Cable Connection e
At this point the only drive that can use the USB connection it the 890 Drive. The USB cable is a Egﬂ;;
standard type A to mini-B, which should not be longer than 3 meters and of good quality shielded COMG
cable. Connect the A connector to any open USB port on the computer and the mini-b connector com7
to the drive's X10 terminal. For a multiple drive systems linked via Firewire, please refer to the MODEM
DSE software manual. AUTO
2400
4800
In the Comm Port drop down list, there are two things that need to be setup for USB 9600
communications; Comm port and baud rate. Make sure there is a check mark next to the port 19200
number that matches the port setup it the beginning of this chapter. The baud rate should have a TELL

T N

check mark next to Auto.

WARNING

Make sure all components on the system are properly grounded, BEFORE connecting any cables
to the drive or computer. Failure to properly ground the system will result in damage to the drive,
computer and cables.
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Serial Cable Connection

For 690+, 650V, 620, 605, 590+, 590, 590SP and 584SV drives you must connect directly to each drive using an
RS232 cable (part number CM351909). For more information refer to the specific drives installation manual.

The 890 can only use the serial cable connection, if it has been setup to work with a modem, refer below.

In the Comm Port drop down list, there are two things that need to be setup for Serial communications; Comm port
and baud rate. Make sure there is a check mark next to the port number that matches the serial port on the
computer. The baud rate should have a check mark next to Auto, except if connected to a 590 drive. For a 590
drive, match the checked baud rate with the baud rate of the drive. If DSE Lite will not communicate to the 590
drive toggle the baud rate setting in the drive to reset the communication port.

Modem Connection

Only the 890 can use the modem connection, please refer to Chapter 3

EtherNet Connection

The 890 is the only drive that can use the EtherNet connection. To connect to an 890 using this option it has to
have an EtherNet communication card installed in slot A and configured with an IP address. For further questions
on how to set up the EtherNet card in the 890 refer to the 8903/EtherNet Manual.

Once the IP address of the drive is known, it has to be entered in the IP window. Click IP under the Comm Port
drop down , and enter the address under the following window:

User input

Enter IP address to connect to...

192.168.1.1
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After clicking ok the program should now be connected to the drive. The speed and reliability of the connection
depends on the speed of the connection and available bandwidth of the internet.

Note Firewalls on the computer and the internet connection will affect the reliability of the connection, and
sometimes will prevent a connection. You may have to shut down or disable any firewalls in the
connection for it to work. Contact your provider or IT department for help on these issuers.

Note The firmware cannot be flashed through the Ethernet connection, there has to be a direct connection to
the drive using a USB cable.

WARNING

When connecting to equipment remotely, certain precautions should be taken. The first
precaution should be to protect the equipment and personnel when connected remotely to avoid
dangerous and unsafe conditions. The second precaution is to keep remote connections disconnected
when not in use to avoid unauthorized or unwanted control of the equipment. It is up to the
customer and end user of this program to make sure proper procedures are followed to prevent
unsafe and dangerous control of the equipment.
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Chapter 2
Configurations

How to create, modify, install and customize a configuration.

Configurations

¢ Introduction

¢ Creating a Configuration

¢ Modifying a Configuration
2
2

Installing a Configuration
Updating a Configuration
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Configurations

Introduction

This chapter will walk you through creating, modifying, installing and accessing a configuration. DSE Lite uses
many interfaces common to Windows and popular Windows applications such as Menus, Tool Bars and Docking
windows. If you are not familiar with these concepts, you may want to refer to Chapter 3 before reading this
chapter.

Note Many commands can be selected in more than one way such as selecting a main menu command (-22),
clicking on a button in a Tool Bar, selecting an option from a popup menu generated by right clicking an
item or typing a keyboard sequence.

Creating a Configuration

First, you need to know the model of drive for which you will be creating a configuration. The 690+, 650V, 620,
605, 590+, 590, 590SP and 584SV drives have a pre-defined Function Block Diagram which can only be ‘wired’
and parameterized, whereas the 890 allows the user to design their own application (user selected Function Blocks)
in addition to the pre-defined Function Block Diagram. As such, when you select an 890 drive, you will have more
options available for configuring it than you will for the 690+, 650V, 620, 605, 590+, 590, 590SP and 584SV
drives.

235 DSE Lite

For starters, we’re going to create a
590+ configuration. Don’t worry if

EEiIe Edit “iew Command Window Help

you don’t have a 590+ drive, all of | tew d Template Help...
this is relevant to the other drives Open r Mew Dialog... Crl+h
as well. From the "File" menu, & OpenoOnline  F9 600 b
select "New—>590->Ver7 B | s b
—2>DEFAULT?7.590”. This is the 590 v
default template for a version 7, Close Al Sg4sy N
590+ drive. A0S b
620 v
Save all FS .
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This should open the following window (your view may be different depending on your setup):

Notice that the template
has multiple function
blocks representing
various drive functions
and that they are pre-
wired for a default
configuration.

The example shown is a
Window view which
allows multiple windows
to be shown at once. If
you are only editing one
configuration, you may
want to expand the
window to the whole
view by clicking the
Maximize button (see
cursor in example).

2% DSE Lite - TH90w7_1*
Edit

Wiewe Command Insert Format Window Help

LR =] B iR nEemj

! File

T590v7_1*

analog Inputi seipolnt Sum 1 Jogizlack P
p——— OPERATING M0 DE[S T “PEED
SUTPUT SPT. 30 | T ER E
UealipraTion- Heatin =4]i03 SPEED | ZPEEL
e b pati o f2lioc sPEED 2 P
10w vaue L POSITIVE] ¢ SRTAKEUP | 10fppap. ge—
URLUE pocmIE[Cn | (oI TAKE UP 2 05T TRE
ANIN 1032 2 C RAWL TP EED CFHNT. bEFI
Horiner 1 FALTE :
1 D E H=peeD
Horiner o 2| B 2mp RATE 3=
nalog Input2 ID';'_:‘T DEXDEAND : = o 4| ERECDEI
| M=ETRCN
| oureuriEs 3 frrt PODITIVE| 2y = o4
10er ﬁ:t'ﬁﬂ:g T ﬁ IWPUT | 5703 . RATR 2
BT P HINFUTO ZETI
1IN UALUE | r— 0% =ETPoIN
AN fiamfE R NP UTLE™ O =FTroIN
Famp & - 105 % e
Dgltal Inputz o | uTPUT 105 |y pERR
AP OUTPUT[ES o BeETET. RATE| oA
QUTPUT pamp MG EALSE FD*—’”’“ElcErPT.:nu L 10| P RESET
':”:'Dl VALUE TRUE :g;_ RAMP 2CCEL THE [ FREZET
BuaLveraLs HpaMP DECELTHE |-
iGN 1o FF E"-"'-B"a'i[lcu:-uc"r.ﬁ.n.ﬁnc EL - Shp Fakc CLLL
FELGE| o HoLe C =PEED pEMAND (TR TZERN S
analog Inputs 0% pamp NPUT PROGRAM ZTO P [ELS AT
T s B o seT =To p [FALZE AT =T:
GUTPUT| =3 Bl RAMP - 1os Y ZERC ZET
e aLiEraTioN 0.5 b amip NG THRESH enz|orof THE C DEABLEN e wpaT
ALIBRATI M- "] b . T Uranns
100 g2 yaLuE [ ENAELED 7o RESET - 1T E’D':'I.T_ﬁ';:":.rgn pELSL PRIERG THE
A i sl - VEABLED|gTEpNaL RESET L A=t NTACTRR BEL - i
Scratch Pad x =

Lser name is 'DSE Lite Manual'

The default setup is for all windows to be open, to move, delete or add windows, refer to Chapter 3.
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File

Edit Miew Command Insert Format Window  Help

The configuration can be
A== | e -~ |ﬁﬁﬁ%|l§lﬁﬂ! saved by clicking on the
&3 Save icon M in the main
- 2| tool bar, or selecting "Save"
s in the "File" menu. A
- standard Windows Save

3 _— dialog will pop up. You can
L& s rename the configuration

Cave i | =3 DSE Manual

e " and save it in any directory
& k== in your file system. Once
@ saved, the asterisk ‘* at the
Desktop o end of the name will

' disappear.

INT
My Diacuments pot 225 DSE Lite - [Test]
— =
E_. 3 ! File Edit Wiew Ot
oo
...................... M_Irl EDmputer e
LISEr natl 7

loading

Inading ig Fiename |8 vl
analag Input 1
by Metwaork | Save as ype: | B30 Configurations [*.530) w | ¥ |—|,:U:FUT

Now that you have the default configuration saved, you are ready to modify it for your application.
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Modifying a Configuration

A configuration can be modified by editing blocks and links, by inserting or deleting blocks (890 only), inserting

text, graphics and forms.

Editing Function Blocks

You can view the contents of any function block in the
configuration by double clicking on the block. For example,

double clicking "Analog Input 3" will open the dialog to the =
right. (=36 Calibration
Click on a parameter’s name to select it. This will cause the (237) Max Value (%) 100%
field at the bottom of the dialog to be updated with (238) Min Value (%) ~100%
information about that parameter. This information will vary
based on the drive you are configuring. If the parameter is
enumerated or a boolean click on [ to select a new value,
otherwise you can directly edit the numeric. %235:' Calibration
{238} Calibration
When you have finished making changes click on "OK" to
exit, otherwise click on "Cancel" to exit and disregard any T
changes you may have made. Note that the & button acts the

same as the “Cancel” button.

Function blocks can be Renamed. To rename a function block, right click with the mouse in the center of the block.
A popup menu should appear. Click on “Rename Block™ to rename the function block. You will also notice that
the popup menu contains a item labeled “Help”. You can click on this to bring up a data sheet for that function

block.

To select a function block either click on it or hold down the SHIFT key and drag the mouse over the function
block. You can select multiple function blocks by holding the SHIFT key down while click on them, or dragging
the mouse over then so that some portion of the function block to be selected are contained in the rectangle drawn

on the screen.
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Configurations

Selected item(s) can be moved by click on an item in the selection and moving them while the mouse button is still
down (dragging). Let up on the mouse button to finish the move. If you hold down the CTRL key before letting up
on the mouse button, the selected item will continue to follow the mouse until it is clicked again to finish the move.

This allows you to move items from one page to another page by changing the current page before clicking the
mouse again. If you depress the ESC key while the items are being moved, but before the move is finished, the
move will be cancelled and the items will go back to their original location.

Editing Links

A link (also known as a connection) ‘transfers’ the output of one function block to the input of another (or same)
function block. The exact details of how this is done varies from drive to drive and type of function blocks being
connected, but all of this, to first approximation, is hidden from the user. For the most part, the user only has to
think of it as a means of specifying that an output from one function block is used
as the input for another.

) Inpart 1 Setp
To select a link click on it. It will change color, purple by default, to indicate that  -uTpuT c
it is selected. Once the link is selected, you can delete it by depressing the TJ'EON B Split 1_‘ EE
Backspace or Delete key or by selecting Delete from the popup menu created LUE ‘El i
when you right click on the link. Using this popup you can also Split the link and, N 1622 mﬂf— 51G
for some drives, flag it as a Feedback. Splitting is covered in more detail below. FEEdﬁJack mjr__ Blﬁl

- Selecting Feedback flags the link as a feedback (for drives that have feedback links). Feedback
_ links are shown as a different color, light blue by default. Most drives update all pre-defined
. ?E function blocks at a periodic rate or scan. Feedback links are processed at the end of that scan

so that its value will be used at the beginning of the next scan. —ux [raer
I . TR
If you right click on a feedback link, you will notice that Feedback is checked to e Split AT

indicate that this is a feedback link. You can click on Feedback again to clear the
feedback flag.

Links are made by connecting an output to an input, in that order. You start by C
placing the mouse cursor near an output of a function block. DSE Lite detects this and changes the shape of the
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Configurations

cursor to an ‘x’ to give visual feedback that the cursor is over an output and that the user can start drawing a
connection. While holding the left mouse button down, drag the mouse cursor to start drawing the link. The link

being drawn will be displayed in red, by default, and when you move the cursor over a valid input it will turn
green, by default, to indicate that you have a valid link selected. Let up on the mouse button to make the

connection.
If you want to change the shape or routing of a link, left click on the link and hold down the mouse button. The line

L ] ENIL R ANIN 1

Famps Famps [EEELLL] Ramps

Cigital nput 2 .
Dialtal nput e Altal inp RARPOU Dl nput RAMP 0L
s OUTPUTR EAap s QUTPUT FEAR I SUTPUTH Eal
HYALUETRUE |- :gi RAMP SCCELT HYALUETRUE :g% RAMP ACCELTI s lUETRUE |- 10| papp accELT
HUALUE FALSE (= HEamp DECELT HWALUE FALSE = RAMP DECELTI HlyalUE FALSE | Wi pappe DECELT
DG IN 1= FF ENAELED copeTan ac DIGIN 1C6 [ ENAELER comsTanT acc TR i ENASLED ¢ o manT s
e gl Lo SR
Analog nput 3 T Pl Znalog nput3 T Pl Bnalog nputs = VEF
0% papp INPUT ,—M-_ 2 RAMP INPUT t
EHITRIT :'D AN TR QD‘* . - MPIHPUT

will change color to indicate that it is selected. Drag the mouse while holding down the mouse button to change the
shape of the link.

EatL R ]

HHIn Il.“_l'— EalL R LI et

Fam p e Fam el F:alTlEl
Cigital nput 2 FAMP O Cigital nput2 BAMP Ol Cigital nput 2 FAMP oL
QUTRUT R SUTPUT RAI _ QUTPUT Ral
UELUETRUE RAMP AZCELT EUaLIETRUE RAMP ACCELT HUALUETRUE [ 10 pamp ACCELT
LlUsLUEFALSE |- 2l RaMP DECELT B IWALUE FALSE |- FAMP DECELT HyaLUE FALSE [ e iBE R AMP DECELT
DG N 1 [ CONSTANT AC DIGIN 1 D CONSTANT ac: DG IN e[ ENABLED) coonsTanT ac

RAMP HOLD Elramp HoLo e PENRANP HOLD
tnalog Nput3 INVERT tnaleg nput3 D) fnalog nput3 =] WVERT
pnaloq heut? RAMP INPUT paloq heutd RAMP INPUT nalod heut? — 2% pamp INpUT

You can also split a link. This will separate the link into two
pieces with a label at the end of each piece. To split the link

either double click on it or right click on it and select Split. If .
you double click the link, you will initially be asked if you
want to split the connection. If you don’t want to see this [1Do not ask again. ves [ Mo

dialog again, check the “Do not ask again” box before clicking
on the “OK” button.
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When you first split the link, DSE Lite will provide default labels. These labels behave very much like function

Cigital nput2

k1

GUTRUT

Famps
FAMP 21

WALUETRUE -
‘WALUE FALZE =

DGIH 1 L FF

EH%HM&'QUTPUT
1

JFamp s INVERT Rl

{E'i' RAMP ACCELT

i pamp DECELT

EMABLEDY - yerranT s
SFE) EAMP HOLD

S L =

—— S RAMP INPUT

ANIN I-.":-'—"
Cigjital nput2

r

VALUETEUE |-
HVALUE FALSE Ger
DIGIN 1026~

COUTPUT—-Eamp e INVERT

EMNAELEL]

Famp s
RAMP 0L
FAl
WL pamp aCCELT
04 pamp DECELT
ER{CONSTANT Ack
RAMP HOLD

snatag npu bl nput2:ouTPUT -mE2EEE yERT
1

RARMP INPUT

BT

L ]
Cdzltal nput2

DG I 1 [ FF

£nalog nput 3
| ——

OUTPUT—m- MY LABEL
qVALUETRUE
qVALUEFALZE [—

MY LABEL e———

102

0]
ENAELED]
CFF]
FALSE

blocks. You can move them around to clean up your drawing. If you double click or right click on either label, you
can Rename them to your own labels.

Famps
FRARP O

F&
RARMP ACCELT
FEAMP DECELT
CONITANT &2
FEARP HOLD
INVERT

EARMP INPUT

You can also connect function blocks that reside on different sheets. To do this, start making the connection the
same way that you would for linking two function blocks that are on the same sheet. Then go to the sheet that
contains the destination function block. You will notice that the connection line(s) will follow you to the next sheet
even though the source function block is not there. Select the destination input to finish the connection. Split links
will be created on each sheet to represent the connection. Just as described above, you can change the name of the

split link as well.

Note In configurations that contains many split links, it may not be easy to visually match up each half of the

connection. To help in this, if you right click on either of the slit labels, you can select ‘Find Matching’ to
go to the matching label of the split link.
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Selecting Function Blocks

You can select a single function block by simply clicking on it with the mouse. Additional blocks may be added to
the selection by hold down the SHIFT key while clicking on them with the mouse. Clicking on an already selected
block while holding down the SHIFT key will remove it form the selection. It is also possible to select a group of
block by holding down the SHIFT key and left clicking the mouse on an empty part of the page, holding down the
mouse button, dragging it over the blocks to be selected and letting up on the mouse button (and SHIFT key) when
done. You will notice that a rectangle will outline the area to be selected while you are dragging the mouse.

_—— —Mopapsre—— —
fnalog nput 2 II:ELLDE-'-.DE-.-'-.ND -
5 % S -
outruTl2 0% -
UeallBRATEN [ gy |HPUTZ
5 |ZAHERATE HPUT1 |
S MAX VALUE o
Humvse | i LLEL
AHIN 1z |2
Ramps
Cigital nput 2 R —
OUTPUT|— W'Y LABEL RANPING
}'—;.-‘-.LUETF:UE = :gi FAMP 4CCELTIME
% IUALUE FALSE |- oo 02} papp D ECEL TIME
oG ime 2 FF ENABLED coporant acceL
a1l FAMP HOLD
W LABEL W 2E=E yyeRT
Analag Rputs j RAMP INPUT
QUTPUT 23% ez panp
HCALERATIN = Enanien] FAMPING THRESH.
HuaxUALUE SRS LED AUTO R ESET
“MINVALUE |~ | ABLED by TERMAL RESET
ANIN oz Y g} FESET VALUE
| MIN.SPEED

Moving Function Blocks

Once you have a block or group of blocks selected, you can move them by clicking on one of the selected blocks
and while holding down the left mouse button, move the block(s) to a new location on the same page. To move to
another page, move the mouse cursor to the lower left page number display, and click the right or left arrow to
select the destination page. Let up on the mouse button to end the move.
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—UIVILEFR Y
gnalog nput? 0% \nEADBAND
| i 105%
ouTPuT(Z 0% .
UealBRATEN [~ o4 |IMPUTZ
| 00% | o value G [MPUT
i | P A linpuTo
MINVALUE 1=
| ANIN 1 g |2
- Famps
ﬁr Clathl hput 2 Ramp ouTpuTH®
C | GUTPUT b W LABEL FAMP NG FE
001% sl UETRUE |- 8L Ramp ACCELTIME |
| 0% ) aLUE FALSE G ENAEL‘E& RAMP DECELTIME |-
DG I 16 MM consTaNT accEL |-
| L
M LABEL mE2LEE yEr B
griled nauli 0%l Ramp INPUT L
| GUTPUT 23 % e pamp B
HealpraTion - 05 % pampING THRESH. |- %
100% ) max yalUE |- EHABLED o 1Ty R ESET =
| SIO% g uslUE | DEABLED| perEppaL RESET |-
BHNIN 18z [ %! RESET VALUE =
| 0% N, sPEED =
—

Selected blocks
are highlighted
with a user
defined color
(default 1s light
yellow).
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Inserting New Function Blocks

Note Inserting new function blocks is only supported for 890 drive configurations.

If you want to follow the examples in this section and do not have w | Black | Carmmand
an 890 version 3 default configuration open, create one now
(New—>890>Ver3->v31 DFLT.890, see Creating a

Configuration).

There are many ways to create new function blocks in the
configuration. One way is to insert a new function block by

selecting it from the “Block” menu. Move it to where you want on

the screen and click again to place the function block.

For example: Click on the Block menu at the top of the screen.

Move the cursor down to select "Logic—=>Counter".

Note For further details of all function blocks, refer to the 890
Engineering Reference manual, Appendix D. Function

block data sheets are available in DSE Lite by right-
clicking a function block and selecting ""Help™'.

Insert Format Window Help
Input = e
ELIM Input
| Wiatchdog Input
ot ;
Macro R
ov
290 L
290 Commes » [ FE]
YT A | M—
Alarms L || I— Yoot
G Profiler L L
Integer 4 AN I 4
- : L T 4 1< | M
Line Drive » 1 et
| Logic » Delay-Off Timer
Logic Gate v oelay-on Timer |
) 42
motion * Drive Start Logic 2

You can also use Edit=>Copy (Ctrl+C), Edit>Paste (Ctrl+V) or Edit-=>Duplicate (Ctrl+D) to insert another copy of
the currently selected block(s) or Edit—=>Import to insert a previously exported (Edit—=> Export) block(s).

Renaming Function Blocks

Right clicking on a function block with the mouse will cause a popup menu to appear

from which you can select various operations related to that function block. One of these
operations is to Rename the block. If you select ‘Rename Block’ you will be asked for a
new name. Names must be unique.
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Configurations

Deleting Function Blocks
Note Pre-defined drive function blocks cannot be deleted. .

Fename Block

Select a block(s) and press the "Delete" or “Backspace” key. Selected function blocks can also W
be deleted by selecting Edit->Delete, Edit—=>Cut (which also places the selection in the

clipboard for Pasting) or right clicking on a block and selecting Delete Block from the popup
menu.

Help

Function Block Data Sheets (Help)

Right clicking on a function block with the mouse will cause a popup menu to appear from  anaioq nputs
which you can select various operations related to that function block. One of these ey
operations is to access the data sheet for the block. If you select ‘Help’, the data sheet for an REname Block
the function block will be brought up in an Acrobat Reader window.

MY LAEEL =

e,
Connecting to Other Drives and Devices

There are four ways to connect to other drives and devices: through the built in digital and analog I/O, optional
encoders cards, optional field bus cards and the P3 MMI serial port.

For built in I/O, encoder cards and serial ports, there are pre-defined function blocks that support these inputs.

m DSE Lite Configuration Tool SSD Page 2-11
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The 590+ and the 690+ also provide pre-defined function blocks for optional field bus tech. boxes.

The 890 drives have application level support for the P3 MMI serial port and optional

field bus cards. It is possible to specify that the P3 MMI serial port will be connected to || BIock [ Command  Insert
a TS8000 HMI display. The application interface to the P3 MMI serial port is through | Input %
Link slot inputs and outputs. Unlike 890 Link systems (supported by the development RUN Input
version of DSE), for a standalone ittatrhdog Input :
E 0~ 890 drives, these slots can only be Output

» address to the configuration in which they reside. Slot inputs
and outputs are selected from the top of the Block menu.
There are three types of inputs (‘Input’, ‘Run Input” and

3ource: | - ‘Watchdog Input’). All three of these inputs will request you
Slot Numbar: | 1 to specify a ‘slot” number when inserting them in the
configuration. This slot number is what is used by the
external device to identify this input. The Source and
| ok QJ | cancel Description fields
are optional.

Descripkion: | Speed Setpoint

Speed Setpoint (- N 1

— i

Similarly, a slot Output will ask you for the destination slot
number (for standalone configurations, the Dest. address is fixed
Dest. Address: to be the same as the configuration’s address). Again, the
Description field is optional.

Link Output

X)

Slok Mumber: | 1

Description: | Measured Speed)|

I Ok M [ Cancel ]

There are numerous application function blocks associated with a field bus option cards. These can all be found in the
‘Block—=>890 Comms’ submenu.
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Block | Command Insert Format Window Help

e B =a g2 E&

RUMN Input
Watchdog Input

Output
Macro

220

| 890 Comms CAN Open

alarms | Caonfral Met |

I,

Dievice Met &3
FB Integer Input
FB Integer Output
FB Logic Input

G Profiler
Integer
Line Drive
Logic

Logic Gate FB Logic Cutput
Motion FB ‘al to Int Output
Sender FB ‘alue Input
Utility FB Yalue Cutput

Yalue
Winders

Firewire
Profibus

*r ¥ ¥ ¥ ¥ ¥y v v v v ¥ | (wv|¥wr

As you can see, there are many
supported field bus (there may be
others not displayed here). The
function blocks that begin with ‘FB’
are input and output blocks shared by
all of the various field buses. They
are used vary similar to the Link
inputs and outputs described above
with the exception that there is no
slot number (this is assigned
internally when you configure the
field bus, see example for Control
Net), you need to pick the correct
block depending on the data type of

the I/O. The block name is used as the description. For example,

Speed Setpoint {I\E§—

sheet of the field bus you are using for more details.

Macros

Macros are a way of encapsulating a group of function blocks into one logical block. The function

Configurations

Mew. .. Inputs Mew, .. Cukputs

Reqister Input
1 Speed Setpoint

Tvpe Reqister
RE&L 1

Cutput
Measured Speed

Tvpe
RE&L

General

Option Slot & (top) E]
MaC Id o

Option Slot

Ciption Slot

T

a ‘FB Value Input’ (Speed Setpoint) can be used to connect a value coming from the field bus
register to the input of an application block and a ‘FB Value Output’ (Measured Speed) can
be used to connect the output of an application block to a field bus register. See the data

A:NIE:R}M&asure{I Speed

MACRO

Biock | command reert. 210Cks inside the macro do not execute any differently than they would if
i " ;t - they were not inside the macro. It is simply a way to hide the details and i
_RLTN rout _| complexity from the top level view of the configuration. Select ‘Macro’ from the Block
';Hab:htrjju ot menu to create an empty macro. To edit the contents of a macro, double click on it with
utout Els * the left mouse button. This will open another window for editing the contents of the
Ly macro. Notice that the tab name is the configuration TEs0v_1* " T890v_1-MACRD |
| Macro . | 1" _ C
L name with the macro name appended to the end. I L
m DSE Lite Configuration Tool SSD Page 2-13
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For an example, we’ll create a macro that multiplies two numbers (an input and a scale) together and adds the

result to a running total which can be reset. First we need to know how to get parameters
Block | Command Insert jn and out of the macro. This is done very similar to how we created I/O to other devices
Input in the previous section. If you click on the tab of the macro to make it the active window,
you will notice that the Block menu has changed slightly. The ‘RUN Input’ and
by ‘Watchdog Input’ items are disabled, and if you click on ‘Input’ or ‘Output’ instead of
QutpLt getting a Link slot I/O block, you will now get a macro input or output when you select

them. These macro 1/0O blocks are diamond shape and just like the field bus I/O block, the
name you give to the block is the name that will be used for that parameter in the macro symbol. So let’s create our
inputs ‘Input’, ‘Scale’ and ‘Reset’ and output ‘Output’. Add in a ‘Value Multiplier’, ‘Value Adder’ and ‘Value
Switch’ to actually implement the macro function and wire it all together. You’ll get something like this:

T890v_1-MACRD

MACRO
IMPUT CUTPUT

SCALE
RESET Q

—_
=
el =

Let’s say you wanted the second input to the macro to be
RESET and the third to be SCALE. Click on SCALE with

MACRO

IrPUT QUTPUT |—

100
SCA
lleez  Rename Block

Delete Block

Miove 'SCALE' Up

Move 'SCALE' Down

Fename "SCALE' h
Celete 'SCALE

Help

Page 2-14 m

the right mouse button and

select Move ‘SCALE’ Down

to arrange the inputs in the

INPUT
SCALE

FEEDBACK S=—m—

=
m
%]
m
-

I
2
=]

(]

100
100]

===

==

|

SEL

LU e

OUTPUT

—w=FEEDBACK

order that we want. In this example, there was only one output, but if there had been
more then one, they could have been arranged the same way. Let’s right click on the
macro again to rename it ‘SUM’ and we’re all done. Our final macro looks

something like this:

sum

~=

100]

IMPUT QUTRUT

RESET
SCALE

by
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Configurations

Text

DSE Lite allows the user to annotate a configuration with their own text. To insert text into your configuration you
start by creating a text box. This can be done by either selecting the Insert—> Text menu item, or by clicking on the
insert text button B in the Text Tool Bar (Chapter 3). When you do this, the cursor will change to shape to +
indicating that it is waiting for you to create a text box. Move the cursor to where you want the top, left hand
corner of the text to be, click on the left mouse button and hold it down while you drag the mouse to where you
want the bottom, right hand corner of the text box to be and left up on the mouse button. The shape will then
change to a text insert box (colored sizing tabs on corners and sides of text area) with an empty selection at the top,
right.
|

123
" Testing .._f:) srall font
&) arial TR [ ! BOLD FEalic Underline

The text that you enter can be formatted as you are typing it by either

selecting a new format from the Format menu or from the Text Tool Bar. Above is an example of many of the
formatting options. ‘Testing’ is in the default font, ‘123’ was in a different, larger font with the color changed for
each digit ( & button), ‘small font’ is 9 point, ‘Times New Roman’ font and the second line is 12 point, ‘Times
New Roman’ font ( [Tmestewremar =12 = bhuttons), centered ( [El button) with Bold, Italics and Underlined text ( B £ &
buttons).

To edit an existing Text object, double click on it with the left mouse button.

Graphics
As with Text (see previous subsection), you can add graphics to your configuration. To insert graphics into your

configuration select the graphic object you want to draw from either the Insert menu or Drawing Tool Bar (see

Chapter 3). i o DB S
Line, Oval, Rectangle and Image. Line Width = selects how thick the line will be for Arrows and Lines and the
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border thickness for Ovals and Rectangles. Line Pattern = allows you to select solid or dashed lines for Arrows
and Lines. It does not affect Ovals and Rectangles. Fill Pattern [ select the interior pattern for Ovals and
Rectangles. Line Color -# selects the color for Arrows and Lines and the border color for Ovals and Rectangles.
Fill Color € select the interior color for Ovals and Rectangles.

The last graphic type is the ‘Image’ [l command. This command allows you to insert an image into your
configuration. This is very useful if you want to add a logo to your configuration. When you select the ‘Image’
command, it will behave very similar to the ‘Rectangle’ command. The difference is that the rectangle you are
dragging will be the ‘frame’ that defines the size of the image you are creating. When you finish drawing the
‘frame’, DSE Lite will ask you to select the image you want to insert (standard File Open dialog; bitmap, gif, jpeg,
icon, windows media file and enhanced meta file format images are supported). When you first create the image, it
will be sized to fit in the ‘frame’
you created, but it will be sized

so that the aspect ratio of the
image is not changed. Once the
image is created, if you resize it, the original aspect ratio will not be

maintained. If, after resizing, you want to reset the image to the
original aspect ratio, select the image and then the ‘Format—> Align’ command.

There a four commands, ‘Move to Front’, ‘Move to Back’, ‘Group’ and ‘Ungroup’, that allow you to manipulate
the placement of graphic objects. ‘Move to Front’ Th and ‘Move to Back’ & are used to change the drawing order
of overlapping graphic items. For example, if you have an oval drawn in your configuration and now want to add a
rectangle with the oval overlapping it, when you insert the rectangle, it will overlap the oval. To change this, select
the oval and then ‘Move to Front’, or while the rectangle is selected, pick ‘Move to Back’:

@ - H - B
Now that you have this oval on top of a rectangle drawing, you may want to move them to another location. To do
this you will have to select them both so that they move together. If you miss selecting one of
them, you will change the drawing when you start the move. To avoid this when you finish @
creating the drawing, you should select both of the items and group them together with the

Page 2-16 m DSE Lite Configuration Tool SSD

DRIVES



Configurations

‘Group’ &l command. When items are grouped, operations such as select, move or delete are

t.\ applied to all items in the group. If you no longer want the item to act as a group, you can
ungroup them with the ‘Ungroup’ &3 command.

Forms

Forms are a means by which project, configuration and user information can be displayed on every sheet of a
configuration or macro. This is mainly intended for printed documentation purposes, but is also useful for online
reference while a configuration is being edited. Special form commands can also be used for creating custom index
sheets for projects as well.

There are two types of forms: internal and predefined. Internal forms are created as part of a configuration.
Predefined forms are created in advanced and stored in DSE’s working folder as XML files with the extension

‘xfm’.

Creating an Internal Form User input

To create an internal form for a configuration, just select ‘Create...’ et new name for Form

from the ‘Insert->Form’ submenu. You will be asked for a name for

the internal form. You can name it whatever you like, but it is a good oy (o

idea to choose a name that indicates that it is an internal form and that
the name does not match the name of any other form. After you pick a name, a new form
editing view will be created in which you can edit the contents of your form (see Chapter 5 for = Tﬁg”“s-l'FE;m i
more details). When you are done editing the contents, close the form editing view and the

newly created form will be displayed in your configuration or macro (as long as ‘View—>Forms’ is checked).
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Inserting a Predefined Form — _
Insert | Format  Window Help
When DSE starts, it searches the working folder for any files with the extension 0 Y -~ R
¢ xfm’. The names of all of these files, without the ‘.xfm’, are added to the | : i:;w :
‘Insert>Form’ submenu. To insert a predefined form into a configuration, just select |o ovl ;
it from the ‘Insert->Form’ submenu. The selected form will be inserted into the 0| Rectangle F8
configuration (or macro) and displayed on the screen (as long as ‘View—=>Forms’ is l@ L2 |
CheCked). Form 4 Create...
GEMERICE [
INDEX1_6&

Editing a Form Cerem [ Fomep ]

To edit a form in a configuration or macro, select the name of the form in the ‘Edit->Edit Form’ submenu. A form
editing view will be created in which you can edit the contents of the form (see Chapter 5 for details).

Deleting a Form | oskisEom v Formi |

Edit Form 3
To delete a form in a configuration or macro, select the name of the form in the ‘Edit->Delete Form” submenu. The
form will be deleted from the configuration or macro.

Installing a Configuration

The 690+, 650V, 620, 605, 590+, 590, 590SP and 584SV drives have a pre-defined drive Function Block Diagram
which can only be ‘wired’ and parameterized, whereas the 890 allows the user to design their own application (user
selected Function Blocks) in addition to the pre-defined Function Block Diagram. As such, 890 drive installation is
different from the 690+, 650V, 620, 605, 590+, 590, 590SP and 584SV drives. We will cover each of these
separately.

Once you have created your own configuration, it can be installed into a drive. If the configuration is not already
open, you will first have to open it. You can open the configuration from the “File=>Open” menu or by clicking on
the “Open” button in the main Tool Bar.
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Install (hon-890)

e Make sure the drive is connected to your PC via an RS232 cable (part number CM3519009).

e Select the correct baud rate for the connected drive from the Comms Icon in the standard tool
bar (or in the Properties View). Except for the 590 you can use the “AUTO” setting and let DSE
determine what baud rate is needed.

e Sclect the correct port if it is not already selected. If the correct baud rate and port is selected,
this will cause the drive type and current running status to be displayed in the Scratch Pad and

Status Bar: Connected to 590 version 5.6' (NOT running at 19200 C

e Select "Command->Install" to install the currently opened configuration into the connected drive.

e The installation progress is displayed on the Status Bar and noted in the Scratch Pad.

InstaII (890)

Make sure the 890 drive is connected to your PC via a USB cable: A to mini-B and that the USB driver is
installed (see Chapter 1 for more details).

e Select the “AUTO” baud rate from the Comms Icon in the standard tool bar (or in the Properties
View).

e Select the correct port if it is not already selected. If “AUTO” baud and the correct port is
selected, the drive type and current running status will be displayed in the Scratch Pad and

Status Bar: Connected to '123' (0K) at 57600 —

e Select "Command->Install At Selected" to install the currently opened configuration into a drive.

e The installation progress is displayed on the Status Bar and noted in the Scratch Pad.
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Autotune

Install a configuration with appropriate motor parameters (see above).

See manual for drive for specific details and safety warnings. Trigger Autotune in the drive (via the MMI) and
wait for it to be completed.

With configuration open, select ‘Command->Extract Drive Parameters’; this will extract tuning (and other)
parameters from the drive and set them in the configuration. This will ensure that your configuration reflects
exactly the state of the drive.

Save the configuration to save the extracted drive parameters. These parameters will now be available if you
need to replace the drive in the future and do a ‘Full Install’ on the new drive.

Updating a Configuration

There are several ways to update a configuration. One is to directly modify it as described in a previous section.

Another is to extract drive parameters from a connected drive into an open configuration using the ‘Command =
Extract Drive Parameters’ command. This command extracts all of the predefined drive parameters from any of the
supported drives and does not require that the open configuration is the one installed in the drive. It will not,
however, extract user defined application parameters from 890 configurations.

For 890 drives, it is also possible to extract the configuration from the connected drive using the ‘File>Extract’
command. The extracted configuration is updated with the current value of all application and drive parameters.
This extracted configuration can then be saved to make a copy of the current state of the drive that can be used for
installing into a new drive if the current drive fails.
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Chapter 3
User Interface

How to control your DSE Lite environment.

User Interface

¢ Docking Windows
¢ Tool Bars
¢ Configuration Windows

¢ Properties
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User Interface

Docking Windows

The DSE Lite framework uses several docking windows to allow the user to interface with the program. Docking
windows are windows that can either ‘float” anywhere in the application window or be ‘docked’ to one of the sides
of the application window. When you first install and launch DSE Lite, it starts with three visible docking

windows:
225 DSE Lite
! File Edit Wiew cCommand  Window Help
Fhd mo|E2 ERFAEB REEAS
Parameters oo
{none)
Properties
Document Settings
Global Settings
B Yersion
AppiYersion 2.00
Wigw Layout current
Language English
Scratch Pad 3 x
DSE Lite wersion 2.00, Copyright Parker Hannifin Corporation 1989-2007. A
Mon Oct 08 14:19:33 Z007
uger name is 'DIE Lite Manual'
loading 'c:%Dze\CELitel.dat' [ID #6145) done.
connected to '123' (8§90 v1.11) - OK, CPU 38.4%, Heap: 27.8%, 0 msgs/s
< 1 >
Ready Connectad to 123" (0K) at 57600 1
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One 1s the ‘Parameters’
windows which is ‘docked’ to
the left side of the main
window. Another is the
‘Scratch Pad’ which is ‘docked’
to the bottom of the main
window. Finally, the
‘Properties’ window is
‘floating’ near the center of the
main window. We’ll talk about
what each of these and other
docking windows do later, but
for now we’re going to discuss
how to view, hide, move, dock
and undock these windows.

To dock a ‘floating” window,
click on the title bar of the
window and drag, with the
mouse button down, the gray
outline of the window to the
side of the main window where
you want to dock it.



Propetties 5]

=

Wiew Layout
Language

current
English

Iy

appears.

21 below:

When the ‘docked’ outline is showing the
new location you want for the window, let
up on the mouse to ‘dock’ the window. In arr curent
» | our example, it would look like the image

222 DSE Lite - [123]

Parameters - 123

Ready

i File Edit Wiew Block Command [nsert Format Window Help

iZEkE =a B2 EERB EEEBRY

o ox

123

q4p x Properties

-~

Mo 4of2 FoH - HIEE v * <

Scratch Pad
loading 'c:%Dse\CELiteld.dat' (ID #6145) done.
CAM support

=]

Wiew Layout current
Language  English

ks

build id = 'llle', connected ko '123' (890 w1.11) - OK, CPU 100.0%, Heap: 27.8%, 0 msgs/s

loading 'c:\Dse4123.890' (880 w1.6) done.

Connected to '123' (OK) at 57600

| UM
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You will notice that when the mouse gets
near the edge of the main window, an
outline of how the window will be docked

aEma::s_Aa

A4k X

Ele> English

The width and height of the window
normally changes when it was docked.
If you want to change this, move the
mouse to the edge of the window
nearest the center of the main window
(it will change shape to indicate that you
are on the edge) and drag it to a new
size.

Docked windows can also be collapsed
into the side of the main window. You
will notice that the docked window has
a small thumb tack in the title bar next
to the close button. If you click on this
thumb tack, the window will collapse
into the side of the main window,
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av x @ creating a tab bar with just the title of the window. If you want to see the collapsed A =
~ ~| | window again, click on the tab and the window will ‘expand” again. When the . Fl
= | 3| collapsed window is no longer being used, it will once again collapse into the side =& =
" | of the main window. If you don’t want this to happen, you can again click on the Viow Layoutlcurert li
;| thumb tack to lock the window in the visible location. Language  English
When there is already a window docked on the side of the main window, it is also possible to dock more windows

there as well. There are three ways this can be done. One is to dock one window above (or below) the already
docked window. Another 1s to dock one windows to the side of the already docked window. By moving the mouse
around the frame of the already docked window, you can see where the docking will take place. Finally, you can
dock the new window on top of the already docked window. In this case the docking outline is shown with a tab:

user name is 'DSE Lite Manual'
connected to '123' (890 +1.11) - OKE, CPU 100.0%, Heap: 27.8%, 0 msgsis

Connected to '123" {OK) at 57600 ( ] MM

When windows are docked in this way, you click on the tab of the window you want to see to make that window

visible.
Properties 1=
-~
- v

Scratch Pad B3 Properties

Connected o '123" (0K at 57600 ( | MR
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Tool Bars

e lonme b=y [ you want to separate a tabbed window, you have to first close each window in the tabbed group.

A wen | Then select the window you want to in the View menu to make it visible again. When it is made

e | visible again, it comes back in the same place that it was docked before being closed. You then need to

e move it (un-dock it) to ‘remove’ it from the tabbed grouping. Then select the other windows in the
s tabbed group to make them visible again.

Tool bars are a graphical means to select DSE Lite commands. In most cases these are the same commands that
can be selected in the Main menu. The advantage of tool bars is that in most cases you can select the command by

just clicking on it without needing to navigate a menu structure.

DSE Lite supports three pre-defined tool bars in addition to the main Menu which is a special case of a tool bar that

cannot be closed or modified. The three pre-defined tool bars are: Standard, Drawing and Text and if they are not
visible, they can be selected via the “View—>Toolbars’ submenu. The Standard tool bar is visible by default and
contains many commonly used commands. The Drawing tool bar contains most of the drawing commands that are
found in the ‘Insert’ and ‘Format’ menus. The Text tool bar contains most of the text commands that are found in

the ‘Insert’ and ‘Format’ menus.

225 DSE Lite

! File Edit View Command Insert Format  Window Hel

molie HEERE EEBERAY
n -~ | I

Docking

In many ways, tool bars are very similar to docking windows described in the previous section. It is possible to

dock them to the main window sides or have them free ‘floating’ as tool windows. By default, the
main Menu tool bar is docked to the top of the main window and the Standard tool bar is docked
below it. If you want to move a tool bar, just click on the left edge (a series of dots) and drag the
tool bar where you want it. If you drag the tool bar away from the main window edge, it will

change into a free floating tool window. You can also drag the edge of a tool window to change its
shape.

Darker 550
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Customizing AlmsuE=,
I It is possible to customize the pre-defined [ass e rence Bumsvi' z:;mizel\ ] & o
=i tool bars or create your own custom tool - — ] | ses
% bars. To do this, click on the downward A Fantt Color
Toobar Optionsj—  pointing triangle in the tool bar (labeled .
‘Toolbar options’). When you click on D i
this, you will be presented with an option to add or remove M= e
items from an existing tool bar or to create a new custom tool iy Ccorered
bar. Reset
Clicking on customize will bring up the tool bar T
Toobers | Commends | Qpions dialog. This dialog allows you to modify an existing %“L-i.—
o ———— || tool bar or create a custom new tool bar. When the —1 | Delete i
e dialog is active, the tool bars on the screen are in edit Name:  Italic
e mode. Click on a tool bar item to select it. Then right I ERE AR
click the item to get a menu of editing options for et Bt fmage
that item. You can add new items to a tool bar by Edlit Button Tmage...
clicking on the ‘Commands’ tab in the customization
dialog and then dragging a command from the list to f'EfatL—gt ISt""e
o [ we | Where you want it in the tool bar. I'rizge ;:d Toxt

Beqgin a Group

Configuration Windows

When you open or create a configuration, DSE Lite creates a configuration window to display the configuration.
More than one configuration may be open at once. Each configuration gets its own window. By default, these are
overlapping windows that can be re-sized. If you would prefer to always have the active configuration window
maximized (fill all the available space in the main window not used by docked windows and tool bars — main view
area), you can set the global property (see Properties section below) ‘Frame Mode’ to ‘Maximize’. In that mode, all
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of the open configuration windows will be maximized by default and can be selected by the tab with the
configuration name in it at the top of the main view area.

At the bottom, left of each windows there is a built in tool bar: |14 «  1oef8 » » | =[100% |+ ¢

This tool bar allows you to quickly navigate through the sheets of the configuration and to easily change the
viewing size. The items have the following meaning:
1 Go to first sheet.

4 Go to previous sheet
1of8  Displays current sheet and total sheet, click on to enter sheet to go to.
»  Go to next sheet.
M Go to last sheet.
= Decrease magnification.
100%  +~| Display current magnification and allow user to select new magnification.

*+ Increase magnification.

Properties

There are many user settable properties that affect the user interface. One of them, ‘Frame Mode’, we saw in the
previous section. Open the Properties window, View=>Properties, to view or change these properties. Below is a
description of all the current properties by category.

Document Settings

Snap to Grid When ‘True’, objects being moved are aligned to user defined grid.

Grid Size Specifies the grid size used for ‘Snap to Grid’ above. Units are 1/720 inch (360 equals %2
inch grid) and should be in increments of 36 to assure proper alignment of connections.
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Blocks
Block Selected Color

Color used for a selected function block.

Advanced Performance Color Outline color for a Advanced Performance function block.

High Performance Color

Connections
New Unconnected Color
New Connected Color
Selected Color
Feedback Color
Type Mismatch Warning

Parameters
Accessed Color
Modified Color

Frame Dependent Color

Global Settings

User Name
Database Path

Acrobat.exe

Page 3-8 m

Outline color for a High Performance function block.

Color used for drawing a new connection that is not matched to an input.
Color used for drawing a new connection that is matched with a valid input.
Color for a selected connection.

Color for a feedback connection.

DSE checks to make sure that the output and input of a connection are of
compatible types. If they are not and Type Mismatch Warning is enabled, then a
warning dialog is displayed.

In online mode, color that indicates that a parameter has been accessed (read).
Color used to indicated that a parameter has been modified.

Color used to indicate that a parameter is frame dependent (will on be set during a
full install).

User name. Used for displaying information and log files.
Path of main database.

Optional full path for Acrobat or Acrobat Reader. Used to launch application for
displaying help files.

DSE Lite Configuration Tool SSD
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Serial Comms Port Communication port to use for connecting to drive.
Baud Rate Baud rate to use for connecting to drive.

Drive Param. View Level  View level for displaying build in drive parameters.

Scratch Pad Font Font used for Scratch Pad docking window.

Montitor List Font Font used for Monitor List window.
Blink Time Length of time for ‘Command->Identify’ to ‘blink’ selected drive.

Frame Mode Determines whether new configuration windows are normal size or maximized.
Configuration Mode Option determines whether a parameter docking window is included with

configuration windows.

Modem
For modem setup and use refer to modem application note under the DSE help menu.
Attention Escape sequence to get modem’s attention while online.
Initialization Initialization string for selected modem.
Dialing Mode Dialing commands for modem (also need to add phone number).
‘Yes’ Response Text response for yes from modem.
‘No’ Response Text response for no from modem.
‘Connect’ Response Text response for modem connection.

Supported Drive Types

Drive Type 1 — 10 List of drive types supported in New and Open menus. By default all drive types
are supported and will show up in the list. If any of the drive types are removed
from the list they will not show up in the list, but can be added back at any time.
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Default Forms

Form 1 -3 Form(s) with the names entered will automatically be inserted into a new
configuration when it is created. The form(s) must be in the working directory
(c:\ssd_link\tools\win3) for DSE Lite, have the same name as the entries in the list
and have the extension ‘.xfm’. See Chapter 5, Editing Forms.

Configuration Description Fields

Field1 -6 Text names to be used for fields 1 through 6 in the Configuration Information
Dialog, ‘Edit->Config. Info’. This makes the dialog easier to use by having a text
description instead of just a field number (say ‘Configuration Name’ instead of
‘Field 1).

Project Description Fields

Field 1 -9 Text names to be used for fields 1 through 9 in the Project Information Dialog,
‘Edit->Project Info’. This makes the dialog easier to use by having a text
description instead of just a field number (say ‘Project Name’ instead of ‘Field 1°).

Version
AppVersion Version number of this copy of DSE Lite.
View Layout Choosing ‘default’ will cause layout to be reset to the default setting the next time
DSE Lite starts.
Language Language in which most text in program is displayed.
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Chapter 4

Online Access

How to access and change parameters online.

¢ The Online Configuration
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The ONLINE Configuration

Note You cannot remove or add blocks and links in ONLINE mode.

To go ONLINE, refer to Chapter 2.

The ONLINE configuration window has "ONLINE" displayed in the title, but otherwise the window looks the
same as the OFFLINE version, but it does have some extra features.

Move your cursor over the "tick" of the parameter in the function box and the cursor will change to an "X". Now

you can:

Page 4-2

Scratch Pad - 00000890;Public /Standalone

Click the input or output of a block to display the Mon Jan 09 15-45:34 2005

actual value from the drive in the Scratchpad. --» 00000890 830SHIP/AN IN 3::%12-04 ... 0.4990% &
< >

SHIFT-click the output of a block to add that
parameter to the Monitor List.

AN N3

SCALE  x1z2-04
OFFSET

CTRL-click the input of a block to change the parameter value. This ' 100 ms
will bring up a dialog prompting for the value to be set.

1of1

Right-click a parameter to display a menu of actions applying to the
parameter (right-clicking a parameter in the Parameters View has the same effect):

Get Display the parameter value in the Scratchpad. o LR
. | — st e T
Monitor  Add this parameter to the Monitor List 100 ms
Chart Add this parameter to the Chart Recorder Moritor
Chart
Scope Add this parameter to the Oscilloscope. Scope

Note that in all cases the Scratchpad will display the latest value.

m DSE Lite Configuration Tool SSD

DRIVES



Online Access

I DSE 890 Monitor List

The Monitor List & E|D) e = A

. . . . Parameter Yalue
The Monitor List displays all the drive parameters that you are AN N 3 %12-04 (B90SHIP/ 000008... 0.1755

monitoring and continuously gets updated values from the drive.

The Monitor List Toolbar

The toolbar contains several buttons:

=&  Open saved Monitor List configuration from a file.
& Save Monitor List configuration to a file.

. Toggle the Monitor List to be on top.

_ Start recording to a file.

B Stop recording.

A Change the font of the items in the monitor list.
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Adding Parameters to the Monitor List

You can add a parameter to the Monitor List either from an ONLINE Configuration or from the ONLINE
Parameter View, e.g. adding the analog input 3 "AN IN 3" results in the following Monitor List. Parameters from
several drive nodes (or modules) in a drive system can be monitored in the same list.

B OSE 890 Monitor List EI@JD]

== NE=]C

Parameter Yalue

AN N 312-04 (BT 2" 0T 3. 02274
Enable

Disable
Delete

You can easily remove a parameter from the Monitor List by a right click and selecting "Delete".

"Set", available for this parameter, brings up a dialog to change the value. Enable and Disable allow this parameter
to enabled or disabled from being updated in the Monitor List.

Monitor List Information
"Parameter" displays the configuration name/instance/parameter name

"Value" displays the current value, constantly updated.
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The Chart Recorder

The Chart Recorder displays the values of the selected parameter(s) and continuously gets updated values from the

drive.

Bl DSE 890 Chart View
@ E S [D e >l 8

E 10 T T T T T T T T T
Time base [5] 20.00 G | AN NN SN SN NS SO S SN I S
Chart Mode False ab N N N N N N N N N
¥ axis aUtorm atic True C8 | NN NN SN SN NS SO S SN I S

Ei _____ T-~-~=7°° % """" % """" T-~"""°°- T-~"""°°- T-~"""°°- T-~"""°°- T-~"""°°- T-~"""°°-
75 USRS SRS SIS S S SN SUNSUNS S S S—

Background color [ ] z55; 255; 2 X ; ;

&rid color WMo oo f : : e

3_{ _______ . [T [T . . . . . .

= . : :
e 73 2 S S

= ooooogeoLesn_1/an Iy 3 [l 255; 0,0 ; ;
Offset 0.00 T [ b b b fre . . . .
Gan 1.00 oo S S S S S S S
Actve Tre A
pen width 2 L B s e e e e e

Here is a typical chart. It shows one parameter, analog input 3 "AN IN 3".
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The Chart Recorder Toolbar

The toolbar contains several buttons:

=  Open saved oscilloscope data or configuration from a file.
H Save captured oscilloscope data and configuration to a file.
&  Print oscilloscope plot.

2 Toggle the Chart Recorder to be on top.

Display/Hide the property grid.
»  Restart data acquisition.

Il Pause data acquisition.

2 Start recording to a file.

= Stop recording.

Adding Parameters to the Chart Recorder

You can add a parameter to the chart recorder either from the ONLINE Configuration or from the ONLINE
Parameter View.

Parameters from several drive nodes (or modules) in a drive system can be charted on the same chart.

Setting-up the Chart Recorder

The Chart Recorder displays menus for Settings and Channels.
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Settings ]
"Settings" displays the settings for how the chart recorder displays the filmielocs i) ALY
information. " s ot s
Background color [ ] 255; 255; 255
arid color BMooo
Time base [s] : This is the time period shown by the chart (x axis)
Chart Mode : When False the chart redraws at the end of the time range; when True the
chart scrolls continuously
Y axis automatic :  When False the Y axis is set by "Y axis min" and "Y axis max"; when True
the Y axis is set automatically
Y axis min : Sets the minimum Y axis for the chart
Y axis max : Sets the maximum Y axis for the chart
Background color : Background color of the chart
Grid color : Foreground color of the chart
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= AN N 3N N 300,00l 255; 0; 0
Channels Ny -
"Channels" lists the current parameters being charted. Every parameter is listed Gain 1.00
by parameter name. You can also set a display color for each parameter. e e

Offset
Gain
Active
Pen width

The Y axis offset
The Y axis gain (amplitude, multiplier)
False suspends the charting for this line, True activates the charting

Sets the line thickness of the charted line (note that the order of parameters
in the list determines the drawn order on the screen - the last parameter to
be added is uppermost)

You can delete a parameter from the chart by right-clicking on its name and |-
selecting Delete.

Page 4-8

Offset

Set
354N )
Active True
Fen width 1
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The Oscilloscope

The Oscilloscope will set-up a real-time data acquisition facility inside the drive firmware, wait for data to be
ready, retrieve the data and display it. This is a tool to capture and display fast signals from external or internal
triggers.

Shown opposite is a typical Bl DSE 890 Oscilloscope

chart, BHSB|([D]w » <A
"FEEDBACKS/SPEED FBK
%" with parameter reference :
"70 6" ———— LEO0_/FEELBACKS ¢ SPEED FBIK %, Gain: 1.000000, Offset:0 000000,
6", - :
= LB90_1 Node 0001
SetLp
All parameter values are = Channels
normalized into 10 divisions LJ
in the main display area. e T
Which is displayed in s Automatic
milliseconds Maximum 11.09
) Minimum 0,00
"Measurement", at the G
Comment
bottom of the screen, o Advanced
displays measured values Cffset 00000 o
such as minimum, maximum Gan - 1.0000 Measurements X1 00000 Y1 0.0000
. . Min 00000 X2 00000 2 0.0000
and RMS. In addition this is - i 000 dr 00000
the display area for the FEEDBACKS / SPEED FBK 040 Mear 0.0000 Y@l 0.0000  X@1 0.0000
Parameter reference: 70.6 RMZ D.0o0oo Ve 0.0000  Xg@y2 0.0000
Cursors. F2FP 00000 dv@x 00000 dX@Y 0.0000
Channel added [ ]
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The Oscilloscope Toolbar

The toolbar contains several buttons:

=  Open saved oscilloscope data or configuration from a file.
H Save captured oscilloscope data and configuration to a file.
&  Print oscilloscope plot.

Copy oscilloscope plot to clipboard

. Toggle the Oscilloscope to be on top.

=  Display/Hide the property grid.

> Download the oscilloscope set-up to the drive.

Manually hold the data if no trigger has occurred.

% Stop polling for the status.

A

Upload the data once available for upload.

Adding Parameters to the Oscilloscope

You can add a parameter to the Oscilloscope either from an ONLINE configuration or from the ONLINE

Parameter View, e.g. adding the speed feedback in rpm from MOTOR CONTROL / FEEDBACKS / SPEED FBK
RPM result in the following oscilloscope view.

Note that only firmware parameters can be scoped.
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Another way to add parameters to the oscilloscope is to right-click on "Nodes", which will bring up a menu with
three choices:

Add Address Add a physical address in the firmware to scope

' Add Address
Add Special Add a special parameter from a pick list Add Special ‘
Add Pref
Add Pref Add a parameter reference number
- -
In all three cases you will be prompted to enter the module node Select Special Address X
number with a dialog. _
! Electrical Angle A

: Electrical Frequency

. Speed Demand

. Speed Feedback

. Speed Integral

: Torgue Demand

: Q-Axis Current Demand (ig)

» Q-Axis Current Feedback {ig)

: Magnetising Current Demand (irmr)
' Magnetising Current Feedback (imr)
¢ D-Axis Current Demand (id)

: D-Axis Current Feedback {id)
: Matar Current Feedback

: DC Link Wvolts

¢ Mator Terminal volts

! Firewire Demand Timestamp
! Firewire Position Demand

! Firewire Speed Demand

! Firewire Acceleration Demand
! Encoder Load Position Timestap
: Encoder Load Position

: Total Position Demand

» Pocitimn Eremr

e In the case of Add Address, you will be prompted to

enter a memory address as a hexadecimal number, e.g.
0x0010.

¢ In the case of Add Special, a pick list will appear, show
opposite. This pick list will depend on the type of
configuration, e.g. Permanent Magnet Motor
configuration will be different from a Volts/Hertz one.

[ B I B N T I LW S

L e el =
mn bk LW =0

¢ In the case of Add Pref, a dialog will prompt for a
parameter reference number, which expects the format:

BLOCKNUMBER.PARAMETERNUMBER

N
= O W o -

L]
SN
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Setting-up the Oscilloscope

The Oscilloscope displays menus for Settings, Cursors and Nodes. The oscilloscope facility will do nothing until it

is set-up.
Description
Show Legend Trie
. Time Scale Milliseconds
Settl n g S Cyclic Mode False
. . . . . k. d col ; ;
"Settings" displays the settings for how the oscilloscope displays the zfiz o 5 2551;225;. &
information.
Description :  Description printed in the legend
Show Legend : Show legend in plot
Time Scale :  Time scale on plot x axis
Cyclic Mode :  Carry out data acquisition in a cyclic manner
Background color :  Background color of the scope
Grid color : @Grid color of the scope
Cursors o
Active Both
"Cursors" controls the cursors for X and Y axis. Channel LES0_1/REFERENCE /F
Active . Select None, Horizontal, Vertical or both cursors
Channel :  Select the channel the cursor should apply to
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Axes
"Axes" are named axis for the plot that can be added by the user. §
Each plotted channel comes with its own axis. In order to group several : Naﬁ:”ai? ”f‘j'; E]OOJ 0; 233
channels into one axis, a named axis can be added and its minimum and e o
maximum values can be specified.

Maximum : Sets maximum value in the data display area

Minimum :  Sets minimum value in the data display area
Nodes
"Nodes" lists in hierarchical order the parameters to scope for each node. -
Once a parameter has been added to the scope, a node will be added " Sefup
automatically. The node name will be the name of the corresponding # Channels

configuration.

Each node entry will then contain a "Setup" item and a "Channels" item.
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Setup

"Setup" contains all the information to set up the data

= Setup
Trace Mode Trigger
Trigger Direction Mo Trigger
Trigger Source FEECBACKS [/ SPEED: FBK

acquisition facility in the drive. Trigger Vale 0,0000

Trace* Mode
Trigger Direction
Trigger Source
Trigger Value
Trigger is Real Value
Trigger Location
Sample Number
Sample Rate

Sample Period

Trigger Location 0
Sample Mumber 100
Sample Rate 1
Sample Period ms

Hold Trace on Trigger, Start, Stop or Full

Falling, Rising or no trigger

Pull down list of available parameters

Numerical value of parameter to trigger on

If true the raw data are scaled.

Location in % of the entire data sample where the trigger is expected.
Number of samples to be acquired

Sample rate in period defined next

Sample period, either milliseconds, or on the fastest task in the firmware, the
pattern generator.

* The term "trace" is used as a synonym for "data acquisition".
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=l Channels
Channels = FeeoBAcks / sPEE 255; 0; 0
"Channels" controls channel configuration and contains a "Channel" Active True
entry per parameter using the name of the parameter. Axis Automatic
. Masdmurm 1.00
This entry also sets a color for the parameter. Mirimum 0.00
Per width 1
Comment
= Advanced
Offset 0.0000
Gain 1.0000

Type : Type can be either value, i.e. a real data type, or an integer.

Active . False suspends the display and setup for this channel

True activates the display and setup.
Axis : The Axis can be assigned automatically, manually with minimum and
maximum specified, or assigned to a named axis.

Minimum : Sets minimum value in the data display area

Maximum : Sets maximum value in the data display area

Pen width : Sets the line thickness of the charted.

Comment : The comment added here will appear in the printed version

Offset : Sets the offset of the channel

Gain : Sets the gain of the channel
A parameter (channel) can easily be removed by a right click on the = Channels

5 " " + == 20

parameter and selecting "Delete". IS ooce M 25500 .

Set
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Using the Oscilloscope

Page 4-16

1. Set the Trace Mode.

2. Set-up the trigger conditions: Trigger Direction, Source, Value, and Type.

3. Set the Trigger Delay (the percentage of total number of samples occurring before the trigger).

4. Set the Sample Number (the total number of samples to be captured)

Total Number of Samples

<

Trigger location (%)

y

LI
A 'Wrigger

time

5. ® Download the oscilloscope set-up to the drive. This will begin the data acquisition.

6. When a trigger occurs, data acquisition continues until the total number of samples are acquired. At this

point, the trace facility will go into a HELD status.

7. DSE 890 will upload and display the captured data.
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Chapter 5
Forms

How to create, edit, save, insert and delete forms.

Introduction

Creating a Form

Inserting a Predefined Form
Editing a Form

Saving a Form

Deleting a Form

® & & & o o
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Introduction

Forms are a means by which project, configuration and user information can be displayed on every sheet of a
configuration or macro. This is mainly intended for printed documentation purposes, but is also useful for online
reference while a configuration is being edited. Special form commands can also be used for creating custom index
sheets for projects as well.

There are two types of forms: internal and predefined. Internal forms are created as part of a configuration.
Predefined forms are created in advanced and stored in DSE’s working folder as XML files with the extension

b

xfm’.

(4

Creating a Form

To create an internal form for a configuration, just select ‘Create...’

from the ‘Insert>Form’ submenu. You will be asked for a name for ey FEEE
the internal form. You can name it whatever you like, but it is a good
idea to choose a name that does not match the name of any other form. After you pick a name, a new form editing
view will be created in which you can edit the contents of your form (see Editing a Form
below, for details). When you are done editing the contents, close the form editing view and 4 Tﬁg”"S—l'Fcr};m i
the newly created form will be displayed in your configuration or macro (as long as

‘View—>Forms’ is checked).
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Inserting a Predefined Form e [ o

Text F4 ] =N
“w o Arrow FS e —
When DSE Lite starts, it searches the working folder for any files with the extension |\ ;e =
¢ xfm’. The names of all of these files, without the ‘.xfm’, are added to the O oval ;
‘Insert>Form’ submenu. To insert a predefined form into a configuration, just select % IBBCE‘”Q'B -
. . . o lmage
it from the ‘Insert->Form’ submenu. The selected form will be inserted into the | Fma T oo
configuration (or macro) and displayed on the screen (as long as ‘View—>Forms’ is - GENERICE
checked). INDEX1_65

Editing a Form [T eream [ Formt N

To edit a form in a configuration or macro, select the name of the form in the ‘Edit->Edit Form’ submenu. A form
editing view will be created in which you can edit the contents of the form.

Note All Forms in the configuration are also displayedin the form window as well. This is help laying out
forms that work together, but it can be very confusing. In most cases it is a good idea to turn off forms
being displayed (View =>Forms) while editing a form.

The Form Editing window that is created looks very similar to a configuration window though the window’s tab
will have both the configuration name and form name in it. Use the same text and graphic commands, described in
Chapter 2, that are used in a configuration window to create your form.

DSE Lite allows you to incorporate user defined configuration and project information into a form as well. This is
done via escape codes in text added to the form. When the text is displayed in the configuration, the field specified
by the escape code is displayed in place of the escape code. All escape codes begin with the ‘** character. Below is
a table of the supported codes and their meaning;:

~A  network node address.
AC  configuration’s name.
D  configuration’s modification date.

AF#  field ‘#° from configuration’s description (Chapter 3, Document Settings).
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AG#  field ‘4’ from configuration’s project description (Chapter 3, Document Settings).

N configuration’s project directory name.
M  configuration’s modification number.
AN total number of sheets in configuration.
AP configuration’s project name.

AR configuration’s revision number.

AS  current configuration sheet number.

Form windows start at sheet zero. Sheet zero is a special sheet for forms. Any content that is added to sheet zero
will be display on all sheets of the configuration in which the form is used. Thus, for many forms, sheet zero will
be the only sheet that has any content. If you do place something on another sheet, those items will only appear on

that same sheet of the configuration in which the form is used.

Saving a Form

When you have a form open for editing, you can save it as file that can then be used as a pre-defined form. Make
sure the form window is active and select ‘File->Save Copy As’ to save the form to a file. Forms being saved for
the first time (name not in pick list) will not be available until the next time you start DSE Lite.

Dilete Farm

d

Deleting a Form |

Edit Form

»

| Form 1 IQ

To delete a form in a configuration or macro, select the name of the form in the ‘Edit->Delete Form” submenu. The

form will be deleted from the configuration or macro.
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Chapter 6

Toolbars & Menus

A listing of all DSE Lite toolbars and menus.

¢ Toolbars

¢ File Menu
¢ Edit Menu
¢ View Menu
¢ Block Menu

DSE Lite Configuration Tool

550

DRIVES

Toolbars & Menus

Command Menu

Insert Menu
Format Menu
Window Menu

Help

Page 6-1




Toolbars & Menus

Toolbars

There are three predefined toolbars: "Standard", "Drawing" and "Text". DSE Lite uses the standard windows
toolbar controls for operating, sizing, moving and customizing, for more information see Chapter 3.

The "Standard" Toolbar

Note Some menu and toolbar functions will be grayed out depending on the drive type or template used.

= Open

is Open Online

E Save

=5 Full Screen

aQ Magnify

B Install at Address

Comm Port

B Restart Node

B Halt Node

B  Identify Node

Get Info.

= Module List

= Monitor List

B Chart Recorder

B Oscilloscope
Page 6-2
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Opens a new configuration. Select "New" to open one of the supplied configurations, or
select from your list of recently opened configurations.

Opens Online window (890)/toggles Online mode for selected drive.
Saves the configuration. An unsaved configuration displays an asterisk in the name.

Displays the selected configuration full screen. Other open configurations are displayed as
tabs. To return to normal view, select View—>Full Screen, ESC or F12.

Left click to zoom in, right click to zoom out. Click the icon again to disable the feature.
Installs the open configuration to the net address selected via Edit/Net Address.

Select Comm. Port and Baud rate to use to connect to drive.

Restarts the application in the selected drive (890 only).

Halts the application in the selected drive (890 only)

Identifies the selected drive by flashing the STATUS LED orange (890 only, flashing time

set in Properties).
Displays detailed information in the Scratch Pad about the selected drive.

Refreshes and displays the Module Status.
Displays the Monitor List window.
Displays the Chart Recorder window.
Displays the Oscilloscope window.

550
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Toolbars & Menus

The standard toolbar is used for the basic operation of the DSE Lite program.

The "Drawing” Toolbar "NoDW=E=0s0 BREE
w Arrow Draws an arrow between two points.
¥ Line Draws a line between two points.
& Oval Draws an oval or circle inside the box, once the mouse key is released.
&1 Rectangle Draws a rectangle or square inside the box, once the mouse key is released.
@ Image Allows an image to be imported into the box, once the mouse key is released.
= Line Width Changes the thickness of the lines for an arrow, line, oval or rectangle. n
= Line Pattern Changes the type of line drawn on the arrow and line commands.
o Fill Pattern Fills the selected oval or rectangle with the pattern selected.
2% Line Color Changes the color of the lines in an arrow, line, oval or rectangle.
& Fill Color Changes the color inside an oval or rectangle
53 Front Move the selected item on top
% Back Move the selected item to the bottom
Group Group the selected items into one object.
. Ungroup Ungroup the selected object into its individual items.

The drawing toolbar is used to document or enhance the configuration graphically. Most of the functions operate
the same as any windows application.
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Toolbars & Menus

The "Text" Toolbar e S 2-AB7UlEE
Text Box Insert a text box

Font Face Select the typeface for the selected text

Font Size Select the type size for the selected text
A  Font Color Select the color for the selected text
B Bold Toggles the Bold attribute for selected text

Italic Toggles the Italic attribute for selected text
u Underline Toggles the Underline attribute for selected text
= Left Justified Text Align the selected text to the left margin
= Centered Text Center the selected text

The text toolbar is used to document or label information in the configuration. Once a text box is created it can be
edited at anytime by clicking inside the box.
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Menus

File

New...

Open

Open Online
Extract

Ctrl+N

F9

>

Close

Close All
Discard

Save

Save Copy As...
Save All

Ctrl+S

Print Setup...
Print Preview
Print...

Ctrl+P

Exit

Toolbars & Menus

‘ Fle Edit View Command [nsert Format Window Help

Creates a new default configuration

Opens a configuration

Opens configuration of selected module in Module List in ONLINE mode

Extracts selected items and save to a file

Closes the active window

Closes all configurations

Removes the configuration without saving

Saves the configuration

Saves the configuration using a new configuration name
Saves all configurations

Setup your printing requirements

Shows how the page will print

Prints the active window

Closes this program

DSE Lite Configuration Tool SSD
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Toolbars & Menus

Edit

Undo Ctrl+Z

Cut Ctrl+X

Copy Ctrl+C

Paste Ctrl+V

Delete

Import

Export

Select All

Duplicate Ctrl+D

Paste Time

Config. Info

Project Info

Insert Sheet

Delete Sheet

Delete Form >

Edit Form >

Find Input... F10

Find Qutput... F11

Performance >
Standard
Advanced
High

Motor Wizard

Page 6-6 m

Reverses your last action

Cuts the selected item from the window (to the clipboard)
Copies the selected item to the clipboard

Inserts the contents of the clipboard to the active window
Deletes the selected item

Import selection

Export selection

Selects all items in the active window

Duplicates the selected item(s)

Pastes today's date and time in the Scratch Pad

Change title bar information for the configuration
Change Project information for the title bar.

Insert a sheet into the configuration

Delete a sheet from the configuration

Delete a Form from list

Edit a Form from list

Find block input by name

Find block output by name

Displays standard blocks in the Block Menu (black)
Displays advanced blocks in the Block Menu (green)
Displays high blocks in the Block Menu (red)
Launches the Motor selection wizard

DSE Lite Configuration Tool SSD
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Toolbars & Menus

View
Eull Screen F12 Toggles full screen view by hiding toolbars etc.
Magnify Magnifies the configuration
Show Grid F7 Shows a drawing grid
Oscilloscope Toggles the Oscilloscope view
Chart Recorder Toggles the Chart Recorder view
Monitor List Toggles the Monitor List view
Parameters Selects the Parameter view
Properties Displays the Properties menu for DSE Lite
Scratchpad Toggles the Scratch Pad view
Toolbars » | Display the toolbars
Standard Toggles the Standard toolbar
Drawing Toggles the Drawing toolbar
Text Toggles the Text toolbar
Status Bar Toggles the Status Bar
Forms Toggles Forms
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Toolbars & Menus

Command

Install Ctrl+G
Full Install

Extract Drive Parameters

Restart
Halt
Identify

Get Info.

Refresh Full
Refresh Partial
Disconnect

Upgrade Firmware
Set Serial Number

Set Performance Level
Write Password

Page 6-8

Installs the open configuration to the net address selected via Edit/Net Address.
Installs the open configuration to the drive selected in the Module List.

Extract the drive parameters into the open configuration.

Restarts the application in the drive selected in the Module List

Halts the application in the drive selected in the Module List

Identifies the drive selected in the Module List by changing the green flashing
STATUS LED on the drive to orange (for approximately 10 flashes).

Displays a set of information in the Scratch Pad about the drive selected in the
Module list

Refreshes and displays the Module List with all drive information.
Refreshes and displays the Module List with partial drive information.
Go offline.

Upgrade drive firmware

Set serial number in drive firmware

Set performance level for drive

Set password into drive configuration to prevent changing.

550
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Insert

Text F4

Arrow F5

Line F6

Oval

Rectangle F8

Image

Form Create...
>

Form X

Inserts a text box

Inserts an arrow between two points
Inserts a line between two points
Inserts an oval or circle

Inserts a rectangle or square

Inserts a selected bitmap image file

Create a new Form in a new view

List of Forms to be inserted

DSE Lite Configuration Tool SSD
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Toolbars & Menus

Format

Align

Text Font...
Text Face
Text Size
Text Color
Bold

Italic
Underline

Ctrl+A

\ A 4

Left Justified
Center Text

Line Width
Line Pattern
Pattern
Line Color
Fill Color

v

Move to Eront
Move to Back
Group

Ungroup

Page 6-10

Align drawing elements

Changes the font attributes of selected text
Select the typeface for selected text

Select the type size for selected text

Select the color for selected text

Toggles the Bold attribute for selected text
Toggles the Italic attribute for selected text
Toggles the Underline attribute for selected text

Aligns selected text to the left, ragged right
Centers selected text

Select a line width

Select a line pattern

Select a pattern fill

Select the line color

Select the fill color

Move selected object in front of other objects
Move selected object behind other objects
Group selected objects together

Ungroup selected compound
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Toolbars & Menus

Window

Cascade Arranges windows as separate tabs

Tile Arranges split-screen windows

Arrange lcons Arrange icons at the bottom of the window

File name ... Each open configuration will show up here for a quick open.
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Toolbars & Menus

Help

Contents... Opens the DSE Lite manual to search the Contents
Index... Opens the DSE Lite manual to search the Index
Search... Opens the DSE Lite manual to search for specific words
About DSE ... Displays the version number and other information about DSE 890
Data Sheets Opens data sheets about DSE Lite

DSE890 Manuals » | Opens Manuals for DSE 890

Release Notes » | Software version release notes

Product Bulletin » | Reported Issues about software and drives

Installing the USB Driver Information on how to load USB drivers

DSE Lite » | Specific Help for DSE Lite software

DSE Support Email DSE support
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